易语言读取MYSQL第三课 服务器、客户端

蚂蚁工作室| 阅读:32 发表时间:2017-10-27 14:34:26 易语言教程

服务器代码

.版本 2
.支持库 sock

.程序集 窗口程序集_启动窗口
.程序集变量 客户, 文本型

.子程序 __启动窗口_创建完毕
.局部变量 取IP, 文本型, , "0"

取IP = 取本机IP ()
输出调试文本 (到文本 (取数组成员数 (取IP)))
.如果 (取数组成员数 (取IP) > 0)
    标签1.标题 = “本机IP地址:” + 取IP [1]
.否则
    标签1.标题 = “获取IP失败,请联系管理”
.如果结束

服务器1.端口 = 到整数 (编辑框1.内容)

.子程序 _服务器1_客户进入

客户 = 服务器1.取回客户 ()
编辑框3.加入文本 (服务器1.取回客户 ())

.子程序 _服务器1_客户离开

编辑框3.内容 = “”

.子程序 _服务器1_数据到达
.局部变量 接收数据, 字节集

接收数据 = 服务器1.取回数据 ()
输出调试文本 (到文本 (接收数据))


.如果 (文本比较 (到文本 (接收数据), “1”, 真) = 0)
    服务器1.发送数据 (客户, “1|服务器发送内容:我需要执行创建SQL命令”, )
    编辑框4.加入文本 (“客户端发送:您点了新建按钮!” + #换行符)
.否则

.如果结束
.如果 (文本比较 (到文本 (接收数据), “2”, 真) = 0)
    服务器1.发送数据 (客户, “2|服务器发送内容:我需要执行删除SQL命令”, )
    编辑框4.加入文本 (“客户端发送:您点了删除按钮!” + #换行符)
.否则

.如果结束






客户端代码

.版本 2
.支持库 sock

.程序集 窗口程序集_启动窗口
.程序集变量 接收数据, 字节集

.子程序 _按钮1_被单击

客户1.连接 (编辑框2.内容, 到整数 (编辑框1.内容))


.子程序 __启动窗口_创建完毕
.局部变量 取IP, 文本型, , "0"

取IP = 取本机IP ()
输出调试文本 (到文本 (取数组成员数 (取IP)))
.如果 (取数组成员数 (取IP) > 0)
    标签1.标题 = “本机IP地址:” + 取IP [1]
.否则
    标签1.标题 = “获取IP失败,请联系管理”
.如果结束


.子程序 _客户1_数据到达
.局部变量 信息, 文本型, , "0"
.局部变量 数量, 整数型

接收数据 = 客户1.取回数据 ()
信息 = 分割文本 (到文本 (接收数据), “|”, )
数量 = 取数组成员数 (信息)
.如果 (数量 ≥ 1)
    编辑框3.加入文本 (信息 [2] + #换行符)
.否则

.如果结束




.子程序 _按钮2_被单击

.如果 (客户1.发送数据 (“1”) = 真)
    编辑框3.加入文本 (“发送成功” + #换行符)
.否则
    编辑框3.加入文本 (“发送失败” + #换行符)
.如果结束


.子程序 _按钮3_被单击

.如果 (客户1.发送数据 (“2”) = 真)
    编辑框3.加入文本 (“发送成功” + #换行符)
.否则
    编辑框3.加入文本 (“发送失败” + #换行符)
.如果结束



源码地址: 链接:http://pan.baidu.com/s/1boGH6yj 密码:vdws

视频:
         


*文章为作者独立观点,不代表蚂蚁工作室的立场
本文由蚂蚁工作室发表并编辑,转载此文章须经作者同意,并请附上出处及本页链接。如有侵权,请联系本站删除。